My Maple Chase thermostat keeps showing the low battery even after I replace them with brand new ones, reason?

NetherCraft 0

I have a Maple Chase thermostat and I have to keep replacing the batteries, days after I just put in new ones. I reset the system every time i put in new batteries. Anything i can do besides get a new one?

9 Answers

  • you reset the t-stat or you turned off power top a/h pop the face of the t-stat theres a little black reset button push it with your thmbnail

  • Maple Chase Thermostat

  • This Site Might Help You.

    RE:

    My Maple Chase thermostat keeps showing the low battery even after I replace them with brand new ones, reason?

    I have a Maple Chase thermostat and I have to keep replacing the batteries, days after I just put in new ones. I reset the system every time i put in new batteries. Anything i can do besides get a new one?

  • Maple Chase

  • You could try cleaning the contacts where the batteries touch in the thermostat. A q-tip with a little alcohol might do the trick. If that doesn’t work, then I’d imagine it’s a problem with the circuitry inside and it’d probably be easier to just replace the thermostat.

  • maple chase thermostat showing battery replace brand reason

  • Had same problem with same stat. This worked for me. Pull cover. heat/off/cool switch to off. Remove batteries. remove red and white wires (which supply 24 volts to the circuit) hit reset button. Wait 20 minutes. restore red and white wires, put in batteries. Hit reset again. Wait 2 minutes and it should work.

    Basically cut all power for a while and reinstall. Manual apparently states batteries should be replaced with switch in off position but my guess is most people don’t read the manual. This looks like a basic software bug. Good luck.

  • Reverse the batteries for 10 seconds, then install correctly.

  • Make sure u use alkaline batts.

Also Check This  Find all values of x such that sin 2x = sin x and 0 ≤ x ≤ 2π.

Leave a Reply

Your email address will not be published. Required fields are marked *